SocksChain

SocksChain Help.

Добро пожаловать в Help программы SocksChain. Здесь вы узнаете основные функции программы, как настроить и работать с ней, список поддерживаемых интернет-клиентов и многое другое. В разделе FAQ вы можете посмотреть часто задаваемые вопросы.


Версии

Что нового...

Версия 3.8
Функциональность программы SocksCAP (автоматический перехват вызовов WinSockets-API и трансляция их через прокси). Удаленное разрешение доменных имен (необходимо если нет доступа к DNS). Поддержка протокола SOCKS4A. Поддержка нестандартных номеров портов. Скрытие настоящего имени хоста и IP-адреса в заголовке письма.

Версия 3.6
Функция автообновления. Более функциональный механизм тестирования proxy-серверов.

Версия 3.0
Поддержка HTTP-проксей с поддержкой HTTP-tunneling. Функция тестирования проксей на работоспособность. Настройка типа подключения к Internet (т.е. можно указать фиксированный прокси, который всегда будет присутствовать во всех соединениях первым). Большая база данных по проксям (несколько сотен адресов).


Анонимность в WEB.

Многие из читающих этот Help уже наверняка задумывалиcь о том, как более незаметно бродить по проcторам Интернета? На первый взгляд может показатьcя, что это никому не нужно, однако в последнее время люди активнее интереcуютcя этим вопроcом. Рано или поздно у каждого появляется к этому интерес или необходимость.

Может быть вы не знаете, для чего вам скрывать информацию о себе, и думаете, что этим пользуются только хакеры? Можно привести несколько примеров, в каких случаях анонимность в Интернете может быть полезной для любого человека:

  • может, вы боитесь оставить резкое заявление в каком-нибудь форуме, так как считаете, что вас могут найти;
  • или вам не удается посетить сайт, на который не пускают по региональным признакам;
  • cидя В IRC-чате не хотите чтобы ваш IP подвергся атакам.
  • или, в конце концов, вы параноик и спокойнее себя чувствуете в полной анонимности.

В любом случае, программа SocksChain решит все эти проблемы.

Это программа не для Спама!

Рассылать спам с помощью SocksChain крайне неэффективно. Дело в том что прокси, которыми он пользуется очень быстро попадают в черные списки почтовых серверов.


О прокси

О proxy-серверах...

Сейчас мы поговорим о proxy-серверах: что это такое, proxy с точки зрения безопасности.

Прокси-серверы изначально служили и служат официально для одной цели - снижения трафика в сети, также часто они используются как Firewall - для защиты локальной сети организации от доступа извне, и как мультиплексор IP-адресов, что позволяет подключить много компьюетеров к Internet, имея в распоряжении только один IP-адрес. В первом случае принцип его работы таков: вы запрашиваете информацию (например, открывая Веб-страницу), но обращаетесь не напрямую к необходимому ресурсу, а через "перевалочный пункт", то есть через proxy-сервер, он же в свою очередь запрашивает необходимые данные с ресурса и отсылает их вам, но также сохраняет их у себя. Это нужно для того, чтобы при повторном запросе этой информации вами или кем-либо другим она не проходила опять своим полным маршрутом, а сразу качалась от proxy к пользователю. Но целесообразно этим пользоваться в том случае, если скорость соединения с proxy-сервером у вас большая, а с остальной частью сети - не очень. Для того, чтобы иметь достаточно большую скорость соединения с proxy, необходимо, чтобы он находился в вашей стране, и еще лучше в вашем городе. Почти всегда у провайдера существует свой proxy-сервер, который обычно находится в этом же городе. Обратитесь к своему провайдеру за дополнительной информацией, если вы хотите использовать его proxy-сервер.

Еще необходимо отметить такой факт, что для разных протоколов (например, HTTP, FTP, SHTTP, Wais, Gopher) необходимо использовать различные proxy-сервера, работающие именно с данным протоколом. Иногда на одном сервере может быть установлена поддержка нескольких протоколов.

Как вы помните, при работе через proxy-сервер к необходимому вам ресурсу обращается сам proxy, а не вы. На рисунке это можно изобразить так:

Значит, думаете вы, ваш IP-адрес и другая информация осталась неизвестна для этого ресурса. Но существует одна проблема: практически ВСЕ proxy-сервера передают всю информацию, которую узнали о вас, вместе с запросом на web-сервер. То есть proxy-сервер полностью прозрачен, следовательно, web-сервер потенциально знает о том, кто (с какого адреса) подсоединялся к нему и что запрашивал. Исходя из этого, предыдущее изображение можно переделать так:

Действительная картина будет выглядеть примерно так. Здесь красная стрелка означает, что вся информация, идущая от вас, проходит полностью без обработки, оранжевая - дополнительная информация от proxy-сервера. Решение у этой проблемы есть: нужно использовать proxy, которые не передают информацию о пользователе, они называются "анонимными". В этом случае первый рисунок уже более правдоподобен.

Но и это еще не полная гарантия анонимности. Даже при использовании анонимного proxy может возникнуть такая ситуация, когда некоторые данные будут передоваться напрямую, минуя proxy-сервер. Мы лишь указали пользователю, что такая проблема есть, и не будем описывать техническую сторону этого случая

Как видите, простые proxy-сервера не являются идеальным решением по части анонимности.


О SOCKS-прокси

Socks...

Слово Socks образовано сокращением от "sockets" (розетки). Socks - это самый лучший способ "зашифроваться" в сети, и о нем мало кто знает. Он обладает несравненными преимуществами, если его сравнивать с http-proxy.

SOCKS - это уже давно разработанный протокол. Он был разработан Дейвом Кобласом (Dave Koblas) из компании SGI. С начала существования протокол пережил несколько больших модификаций. На сегодняшний день в работе две версии протокола: Socks4 и Socks5. Сейчас все большую популярность получает пятая версия протокола, т.к. она более прогрессивная, чем четвертая. Протокол представляет собой транслятор (что-то вроде proxy-сервера), но, в отличие от обычных proxy, Socks-клиент находится между прикладным и транспортным уровнем в сетевой модели OSI, Socks-сервер находиться на прикладном уровне. Это означает, что такой сервер не привязан больше к протоколам высокого уровня (таким, как http, ftp и др.). Сам протокол разработан для того, чтобы приложения, работающие на основе TCP и UDP, могли использовать ресурсы сети, доступ к которым ограничен архитектурой или настройками сети. Например, доступ к ресурсам Интернета из локальной сети приложениями, у которых не предусмотрена работа с использованием proxy-сервера. Сервер SOCKS предназначен для прозрачной работы с такими запрещенными ресурсами и предоставляет возможность перенаправления запросов через сервер на удаленную машину и прозрачную передачу трафика после установления соединения.

Итак, существует две версии протокола - Socks4 и Socks5. А также подверсия Socks4a.

  1. Socks4 - решает вопрос незащищенного пересечения межсетевых экранов приложениями клиент/сервер, основанными на протоколе TCP.
  2. Socks5, [RFC 1928], является дальнейшим расширением четвертой версии SOCKS. Он включает в себя UDP, расширяет общую рамочную структуру, придавая ей возможность использования мощных обобщенных схем идентификации, и расширяет систему адресации, включая в нее имя домена и адреса IP v.6.

Проще говоря, Socks4 поддерживает TCP, а Socks5 поддерживает TCP, UDP, авторизацию и удаленный DNS-запрос.

Теперь рассмотрим, как эту технологию можно использовать для анонимности в Интернете. С помощью нее можно решить сразу несколько основных проблем, с которыми мы столкнулись, разбирая proxy-серверы, работающие с протоколами высокого уровня. На первый взгляд Socks - это обычный proxy-сервер, но, рассмотрев его подробнее, можно сразу увидеть его основные преимущества.

  • Так как Socks работает напрямую с TCP, он не имеет никакого отношения к модернизации заголовков http-запросов. Socks-сервер будет передавать все данные в чистом виде от первого лица - то есть от себя. Другими словами, можно сказать (используя терминологию из http), что все Socks-серверы "анонимные". Socks не передает информацию о вашем IP-адресе, потому что это никак не предусмотрено его технологией. Соответственно, отпадает множество проблем. Кроме того, что он не передает IP-адрес, он естественно, как было написано выше, не модернизирует http-заголовки, а это означает, что web-сервер никаким образом не может определить, что вы используете proxy-сервер. Для него работа с вами будет абсолютно аналогичной, как если бы вы работали непосредственно с web-сервером, с той лишь разницей, что он будет видеть совсем другой IP-адрес, а точнее, IP-адрес Socks-сервера.
  • Вы еще не забыли проблему с использованием различных прокси серверов для разных протоколов? HTTP, FTP, SHTTP, Wais, Gopher... Так как все эти протоколы (в браузере) работают на основе TCP (протоколе более низкого уровня), то Socks-прокси без проблем берет их всех на себя. То есть, больше не надо мучаться, прописывая для каждого протокола свой proxy-сервер, а тем более искать их. Достаточно одного Socks.
  • Технология Socks легко поддерживает выстроение в цепь. Более подробно о цепи из Socks-прокси читайте в следующем разделе.
Полезные ссылки на сайты, посвященные SOCKS:


Цепь

Цепь из Socks-серверов.

Цепь из прокси серверов представляет собой аналогию этой самой конструкции - то есть цепи. Здесь все очевидно: первое звено - это www-клиент (браузер), последнее - www-сервер. Между ними можно поставить неограниченное количество proxy-серверов.

Как уже было сказано, технология Socks поддерживает выстроение в цепь. Здесь следует отметить, что некоторые HTTP proxy-сервера тоже могут выстраиваться в цепь, но в этом случае возникает много проблем. Во-первых, из 100% работающих proxy-серверов анонимными будут примерно 10%, из них, возможно, 1% будет поддерживать возможность перенаправлять запросы, то есть выстраиваться в цепь. Во-вторых, использование такой возможности HTTP-прокси браузером прямо не предусмотрена, но если все же использовать некоторые методы для этого, то останется множество брешей, главной из которых будет потенциальная возможность передачи данных напрямую, минуя прокси. Для этого есть средство лучше - это Socks. Так что же дает возможность выстраивания в цепь Socks-серверов? Socks-серверы могут находиться в разных частях планеты, передавая информацию друг другу по вашему желанию. Данные, которые "ходят" между браузером и web-сервером, будут передаваться через все серверы, которые вы выстроили в цепь, возможно не раз обойдя земной шар, пока не достигнут цели. Как понимаете, возможность вашего "вычисления" в такой ситуации представляется маловероятной.

Возможные проблемы:

  • Даже если один из серверов в цепи будет неработоспособен - вся цепь не будет работать.
  • Если сделать слишком длинную цепь - работа может существенно замедлиться.


Принцип работы SocksChain.

SocksChain - программа, позволяющая работать через цепочку SOCKS или HTTP-проксей для того, чтобы скрыть истинный IP-адрес. SocksChain может работать как обычный SOCKS-сервер, транслируя запросы по цепочке проксей, также он может быть использован с клиентскими программами, которые не поддерживают протокол SOCKS, но работают с одним TCP-соединением, например TELNET, HTTP, IRC... (FTP использует 2 соединения). При этом ваш IP-адрес не будет появляться в логах сервера или заголовках почтовых сообщений.

SocksChain так транслирует TCP-обращение клиентской программы, что оно последовательно проходит через цепочку проксей. Сам SocksChain соединяется только с первым элементом этой цепочки. В свою очередь, тот соединяется со вторым и т.д...При этом возможность отследить, откуда инициировался запрос, исходя из логов на сервере очень сложно. Для этого нужно будет последовательно анализировать логи всех промежуточных звеньев цепи в обратном порядке. Если где-то логов не ведется, то нить будет потеряна. Это теоретически дает очень высокую степень анонимности. Но в ущерб скорости передачи данных, так как она обратно пропорциональна длине цепочки.

Для SocksChain полезны только два вида универсальных прокси, которые позволяют транслировать любые TCP-соединения (а не только например HTTP и FTP). Только они позволяют создавать цепочку:

  • SOCK4 и SOCKS5 сервисы. По уволчанию им назначается порт 1080. SOCKS5 - является наиболее универсальным сервисом, так как позволяет не только устанавливать TCP-соединения но и открывать порт для входящих TCP-соединений (операция BIND) и передавать/принимать UDP-датаграммы.
  • HTTP-прокси с возможностью SSL-tunneling. Порт по умолчанию 8080. Это менее универсальный сервис, чем SOCKS5, но зато гораздо более распространенный.


SocksChain Help

Настройки SocksChain

На главной панели программы содержится несколько разделов, а также иконки для быстрого доступа к некоторым функциям:

File

Export...- сохранение списка proxy-серверов в текстовом файле (для быстрого доступа к этой функции можно нажать на [image]).
Import...- открытие ранее сохраненного списка proxy-серверов в виде текстового файла (для быстрого доступа к этой функции можно нажать [image]).
Exit - выход из программы.

Структура текстового файла при работе с функциями Export/Import имеет вид:
IP[:port]
где IP - IP-адрес proxy-сервера, port - необязательный параметр, это порт, который работает на этом прокси (если портов несколько, то записывается тот, у которого выше приоритет; высший приоритет имеет порт протоколов Socks4/5, затем - HTTP).
Вот пример записи файла:
168.58.190.66:80
65.64.123.213
217.157.209.194:1080
Вы можете вручную редактировать,удалять и добавлять новые прокси в этот файл, а потом импортировать его в SocksChain с помощью функции Import.

View

Show Splash - показывать или нет заставку при запуске.

Service

New - создание нового сервиса (для быстрого доступа к этой функции можно нажать на [image]).
Delete - удаление сервиса из списка (для быстрого доступа к этой функции можно нажать на [image]).
Modify - изменение настроек сервиса (для быстрого доступа к этой функции можно нажать на [image]).

Tools

Options - основные настройки SocksChain.
Proxy manager...- менеджер proxy-серверов (для быстрого доступа к этой функции можно нажать на [image]).

Help

Contents - Help.
Forum - форум.
Tech support - техническая поддержка.
Register - регистрация.
Check for new version - проверить, есть ли новая версия программы на сайте.
About...- о программе.

Теперь подробнее о некоторых функциях:

Servise.

При создании нового сервиса или модификации имеющегося у вас откроется окно настроек сервиса. Его основные элементы:

  • Name - имя сервиса, никакого функционального назначения не несет, просто должно быть уникальным.
  • Accept connections on Port - порт на вашей машине, не занятый никаким другим сервисом. Может назначаться произвольно. Именно это число нужно указывать в настройках клиентских программ в качестве порта сервера или прокси. Если, например, мы выбрали порт 1081, то в почтовом клиенте пишем SMTP-server: 127.0.0.1 порт 1081 (127.0.0.1 всегда обозначает ту же машину на которой запущен клиент).
  • Auto-creating chain - автоматическое создание цепочки. Если выбрана эта опция, надо очистить list-box "Chain".
  • Change the chain every ... s - время, по прошествии которого SocksChain будет менять звенья цепи, то есть прокси, на другие, указанные в Chain list-box. Это повышает общую безопасность соединения.
  • Chain Length ... proxies - длина цепочки, которая должна быть создана автоматически. Рекомендуемые значения: 2-5. Большая длина - это меньшая вероятность обнаружения но и меньшая скорость.
  • Chain list-box - два окна: первое - из этого списка будет выбираться прокси, с которого надо начинать цепочку (ели он пуст, то SocksChain будет работать как Socks-прокси); второе - из этого списка будет выбираться прокси, которым нужно заканчивать цепочку. Добавлять (из списка проксей в правом окне), удалять и менять их настройки вы можете с помощью кнопок Add, Delete и Edit соответственно.
  • Target (host:port) - пара вида host:port, которая служит целью клиентов, не поддерживающих соединение через прокси. Например, для телнета: somehost.com:23. Этот адрес не обязан быть прокси.
  • Substitute HELO for SMTP traffic - подменять имя хоста и IP-адрес в заголовках электронных писем.

Следует отметить, что по умолчанию при установке создается сервис на порту 1081 (не 1080 потому, что часто порт 1080 занят каким-то стандартным прокси, например WinGate). Вы можете поменять номер порта на любой свободный на вашей машине. Соответсвенно, в клиентской программе вы указываете 127.0.0.1:1081 как адрес сервера. То есть, надо соединить вашу клиентскую программу, SocksChain, промежуточные прокси и сервер назначения в логическую цепочку.

При обращении клиентов к сервисам в правой панели главного окна отображается процесс последовательного подключения к элементам цепочки.

Options.

Здесь находятся все основные настройки SocksChain.

Вкладка General:

  • Number of threads - число одновременно работающих потоков. (задает только порядок этого числа, т.е. реально потоков может быть и больше раза в 2, в зависимости от конкретно выполняемых операций). Рекомендуемые значения: от 1 до 20.
  • Time-out ... s - это время, в течение которого SocksChain будет ждать ответа от сервера после посылки ему запроса. Если увеличить его относительно значения по умолчанию, то после тестирования прокси их количество в списке будет больше, но там будут содержаться медленно работающие прокси. Если же уменьшить это значение, то количество прокси будет меньше, но зато все они будут быстро работать.
  • Sessions time out after ... seconds of inactivity - это время, в течение которого программа ждет ответа от прокси во время работы. Если сервер неактивен все это время, то SocksChain заменяет его в цепочке на новый.
  • Enable connections only from localhost (127.0.0.1)
  • Save Log to file SocksChain.log - записывать логи в файл SocksChain.log.
  • Fast disconnect - быстрое рассоединение.

Вкладка Proxy:

На этой странице задаются настройки первого прокси, через которого будут производиться все действия программы, в том числе и тестирование проксей. Это бывает необходимо, если у вас не глобально-доступный IP-адрес, а внутренний, в вашей локальной сети, и вы выходите в Интернет через этот прокси.

  • Directly/Through SOCKS4 server/Through SOCKS5 server/Through HTTP Proxy - Нет прокси/Socks4 прокси/Socks5 прокси/HTTP прокси.
  • Server - имя или IP-адрес прокси.
  • Port - порт, на который соединяться.
  • User - имя пользователя (если это необходимо в вашей сети).
  • Password - пароль (если это необходимо в вашей сети).
  • Resolve domain names locally

Вкладка Upgrade:

  • Enable Interaction with site (strongly recommended) - поддерживать интерактивную связь с сайтом (очень рекомендуется).
  • Automatically download new version if available, and save it to - автоматически скачивать новую версию программы, если она появилась, и сохранять ее в...(в поле нужно указать путь).
  • Automatic upgrade - автоматическое обновление.

Proxy manager.

Этот менеджер занимается всей работой по поддержанию базы данных по проксям. Вот его функции:

  • Add - добавить прокси в список (вы вписываете имя или IP-адрес прокси).
  • Delete - удалить выбранный прокси из списка.
  • Edit - редактировать настройки прокси (при этом откроется страница с настройками прокси, где вы можете поменять имя или IP-адрес прокси, включить или выключить поддержку Socks4,Socks5 и HTTP, изменить номера портов).
  • Update list - обновление списка с сервера.
  • Test all - тестирование всех серверов на работоспособность (по умолчанию тестируется соединение с сервером www.microsoft.com порт 80, как наиболее мощном и доступном отовсюду).
  • Test selected - тестирование только выбранных прокси.
  • Stop test - остановить тестирование.

В правой части находится окно со списком прокси-серверов. Если на прокси работает поддержка хоть одного протокола, он помечается [image]. Если же прокси не работает, то он помечается [image].

Программа автоматически оповещает сервер о степени работоспособности используемых прокси-серверов. Таким образом, список проксей ведется распределенным образом. Скрипт на сервере собирает статистику о наиболее часто используемых проксях. Это важно, так как часто свободный доступ к прокси закрывают.

SocksChain хранит список проксей в виде XML-файла, который находится в папке X:\WIN_DIR\Application Data\Ufasoft\SocksChain и называется SocksChain.xml (здесь X: и WIN_DIR - имя диска и директория установки Windows соответственно). В этом файле хранится таблица известных проксей. Вы можете пополнять этот файл как из программы, так и вручную в воответсвии со следующим образцом:

<SocksChain>
<Proxies>
<Proxy IP="12.1.68.100" SOCKSPORT="1080" SOCKS4="" SOCKS5="" />
<Proxy IP="12.2.81.50" HTTPPORT="8080" HTTPTUNNEL=""/>
</Proxies>
</SocksChain>

Присутсвие параметра IP обязательно. Присутсвие остальных параметров необязательно и означает:

SOCKSPORT - порт для использования сервисов SOCKS4/5 (по умолчанию 1080)
HTTPPORT - порт для использования HTTP-tunneling (по умолчанию 8080)
SOCKS4, SOCKS5, HTTPTUNNEL - параметры без указания значения. Их присутствие означает, что данный IP-адрес проверен на функционирование соответствующего сервиса.

Если на одном IP-адресе работает сразу несколько видов проксей, то приоритет имеет SOCKS5, затем SOCKS4 и HTTP.


SocksChain Help

Взаимодействие программ с SocksChain.

Для многих программ не обязательно настраивать параметры Socks-сервера (тем более некоторые программы не имеют встроенной поддержки SOCKS). С помощью SocksChain этот процесс стал гораздо проще: вы просто нажимаете правой кнопкой мыши в окне Application

и открываете пункт Add. Затем нажимаете на кнопку Browse и указываете путь к программе. В поле Title вы можете назвать программу любым именем. Вот и все, вся настройка завершена (еще более простой способ - это просто зажать левой кнопкой мыши ярлык или сам exe-файл необходимой вам программы и перетащить в окно Application). Для запуска программы нажмите на ее название правой кнопкой мыши и выберите пункт Start, или же проще просто два раза нажать на нее левой кнопкой мыши.
Для удаления или изменения настроек выбранной программы после щелчка правой кнопкой мыши выберите в меню пункты Delete или Properties соответственно.

Список известных программ, поддерживающих такой способ работы:

  • The Bat
  • MS Outlook
  • MS Outlook Express
  • MS Internet Explorer
  • Mozilla
  • mIRC

К сожалению, большинство FTP-клиентов не могут работать через SOCKS, так как FTP использует не только исходящие TCP-потоки, поэтому их перенаправление через SocksChain невозможно.


SocksChain Help

Общая настройка.

В общем виде ее можно изобразить так:

  1. Если программа поддерживает соединение через прокси, то создаем в SocksChain новый сервис, указываем номер порта (например, 1081, или любой другой незанятый) и устанавливаем настройки так, чтобы SocksChain работал как первичный Socks-сервер (как это сделать, написано в разделе настроек программы). Далее открываем окно настроек нужной программы и находим настройки прокси. Для каждого протокола прописываем IP-адрес 127.0.0.1 и тот порт, который вы назначили сервису (в нашем случае это 1081).
  2. Если программа не поддерживает соединение через прокси, то также создаем в SocksChain новый сервис, только в поле Target (host:port) указываем имя или IP-адрес хоста, который служит целью клиентов, не поддерживающих соединение через прокси, и через двоеточие номер порта. Например, для телнета: somehost.com:23 или для почтовых программ: smtp.mail.ru:25 (соответсвенно, в вашей почтовой программе прописать SMTP сервер 127.0.0.1:1081 (или другой порт, который вы указали при создании сервиса).Этот адрес не обязан быть прокси.


SocksChain Help

Advanced Direct Remailer (ADR).

ADR - это программа, котороя позволяет создать SMTP-сервер на вашем компьютере. Она имеет встроенную поддержку Socks5, поэтому мы можем настроить ее для работы с SocksChain:

Откройте меню "Отправка" ("Delivery") на главной панели. В нем выберите пункт "Настройка..." ("General Settings...").
В появившемся окне перейдите на вкладку "Прокси" ("Proxy").
Отметьте галочкой "Подключаться через прокси-сервер Socks v5" ("Connection through Socks v5 proxy server").
В открывшемся поле "Адрес" ("Adress") введите 127.0.0.1 , в поле "Порт" ("Port") введите тот порт, который вы установили при настройке сервиса в SocksChain (Настройку сервисов смотрите здесь). Если вы ничего не меняли в настройках, то номер порта, заданный по умолчанию, 1081.
Проследите, чтобы пункт "Использовать аутентификацию (RFC1929)" ("Use RFC1929 authentication (cleartext)") не был отмечен галочкой.
Некоторые реализации прокси-серверов, например, WinGate 3.0, некорректно работают по протоколу UDP, и в таком случае необходимо использовать маппинг (отображение) портов для работы с DNS по протоколу UDP. Если в конце вашей цепочки прокси стоит именно такой сервер, то поставьте галочку напротив пункта "Маппинг для DNS (специально для WinGate)" ("Use mapping for DNS").
Нажмите на кнопку "OK" снизу окна для принятия текущих настроек.

В SocksChain, начиная с версии 3.8, появилась функция "Substitute HELO for SMTP traffic". "HELO" - это команда, используемая для представления SMTP-серверам. Полученную с помощью нее информацию (имя хоста, IP-адрес клиента) сервер добавляет в заголовок письма. Чтобы избежать этого, надо поставить галочку напротив этого пункта в окне настроек сервиса.

При использовании Advanced Direct Remailer или какой-либо другой программы, требующей поддержки Socks5, вы должны быть уверены, что в конце вашей цепочки проксей стоит поддерживающий Socks5 сервер.

Примечание: из-за злоупотребления Socks-проксями спаммерами (это люди, которые без разбора (и незаконно) посылают незапрашиваемые рекламные объявления по большому количеству e-mail адресов), некоторые Socks-прокси блокируют порт 25 и непригодны для пересылки почты. Существуют базы данных по серверам, замеченным в спаммерстве (например, MAPS Realtime Blackhole List). Письма от таких серверов не принимаются многими известными почтовыми серверами. Поэтому сложно найти Socks-прокси, который надежно доставит почту всем адресатам (в то время как для спаммера результат доставки 80% процентам от всех адресов будет прекрасным, это недопустимо при законной, деловой пересылке писем). Будьте осторожнее при работе с Socks-прокси, через который у вас работает ADR, не перегружайте его, не посылайте спам, иначе вы можете разрушить ему всю репутацию и он будет уже непригоден для использования в деловых целях, а всем нормальным пользователям, работающим через него, придется искать другой прокси.


ЧаВо

FAQ.

Работает ли программа с modem dial-up или DSL connection, T1?
Работает со всеми видами соединений, поддерживающих TCP/IP. В SocksChain нет аппаратно-зависимых компонентов.

С какими операционными системами работает?
Windows 98/ME/NT4/2000.

Сколько занимает места на диске и какой ресурс съедает?
Установочный комплект занимает около 400 Kб. На диске - около 750 Kб. Основной потребляемы ресурс - Sockets. На Windows 9x их число ограничено. SocksChain в обычном режиме создает по 1-му сокету на соединение. Во время создания цепочки используется значительно большее число сокетов.

Нужно ли перезапускать ПК после инсталляции?
Нет.

Как знать, что программа загрузилась и работает?
В том, что программа действительно успешно создала цепочку и работает, можно удостовериться, если клиентская программа работает через SocksChain (то есть настроена на 127.0.0.1:1081 по умолчанию).

Я использую ICQ, будет ли программа работать с ICQ, нужно ли мне что-то менять?
В SocksChain ничего не требуется менять. В настройках ICQ меню ICQ|Preferences|Connection|Firewall|Socks5| SOCKS = 127.0.0.1, port = 1081.

Как отразится установка программы на работу с Браузером и с электронной почтой (Outlook и тд.)?
Если в браузерах и других клиентах не менять настройки, то никак. Для работы через SocksChain (то есть для обеспечения анонимности IP) в настройках InternetExplorer прописать работу через SocksProxy 127.0.0.1 Port 1081. Если клиент не поддерживает работу через SOCKS, как например Outlook, то в SockChain создать Listener и установить в нем поле TARGET на целевой сервер. Например, для почтовых программ: smtp.mail.ru:25. Соответсвенно в Outlook прописать SMTP сервер = 127.0.0.1:1081 (или другой порт, на который вы создали Listener).

Не становится ли мой ПК доступным для хакеров после установки программы?
Вообще говоря, он становится несколько уязвимым, поскольку если хакер обнаружит, что ваш порт 1081 работает как SOCKS, то он может им воспользоваться для проникновения в другие компьютеры, в том числе и ваш. Рекомендуется использовать программу совместно с Firewall-ами, например @Guard или ZoneAlarm. В будущем планируется ввести возможность запрета на соединения извне.

Как остановить работу программы?
Если программа работает не в режиме "Service" то просто закрыть окно. А сервис можно остановить штатными средствами Windows из ControlPanel.

Есть ли функция деинсталляции?
Есть. Но при этом не очищается Registry, чтобы оставить настройки. При каких либо фатaльным проблемах с программой рекомендуется потереть следующие ветки вручную через regedit:

HKEY_LOCAL_MACHINE\Software\Dsoft\SocksChain
HKEY_CURRENT_USER\Software\Dsoft\SocksChain
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SocksChain

Как использовать программу с Advanced Direct Remailer (ADR)?
В SocksChain ничего можно не менять. В ADR поставить работу через SOCKS-прокси 127.0.0.1 port = 1081. SocksChain сам при первом обращении создаст цепочку заданной длины (по умолчанию 2). Если какой-либо из серверов в цепочке не работает, можно отключить "Auto-chain" и задать сервера вручную. Процесс поиска работающей цепочки иногда занимает несколько минут, программа может даже повиснуть. Но если при этом цепочка создана то она запоминается и при последующих запусках будет использоваться.


Регистрация.

Если вы хотите использовать программу после окончания испытательного периода ее необходимо зарегистрировать. Это можно сделать одним из следующих способов:

  • Через платежную систему WebMoney:

http://www.exaccess.ru/asp/pay.asp?id_d=7378 ( 14 WMZ, эквивалент 420 руб.)

  • Банковским или почтовым переводом через систему SoftKey:

http://www.softkey.ru/catalog/basket.php?prodid=2059&quantity=1&referer1=sockschain (цена 500 руб.)

Оплата электронным способом дешевле.

Внимание!

Регистрация дает право право пользования программой текущей и всех последующих версий, независимо от последующего изменения цен и функций. Не потребуется доплачивать за обновления.

Регистрируйте программу только если уверены, что она вам нужна и вы понимаете как ей пользоваться. Именно для этого и предоставляется испытательный период. Отменить регистрацию и вернуть деньги не получится.

Как получить лицензию бесплатно

Это возможно если вы окажете помощь в разработке. Например обнаружите серьезную ошибку в работе, или первыми переведете страницы справки на какой-либо язык.


SocksChain Help

Как с нами связаться.

Web-страница: www.ufasoft.com

Пишите нам: support@ufasoft.com